Library / Windows

openfiles.exe

Displays the current open files list · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • opnfiles.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: openfiles.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\openfiles.exe'
    - OriginalFileName: 'opnfiles.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
opnfiles.exe2x64, x8610.0.26100.4202Host scan✓ 2

InternalName: openfiles.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
ac9b1f4261a0…10.0.26100.4202x86opnfiles.exeHost scan✓
2dd6dba5c159…10.0.26100.4202x64opnfiles.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.