Library / Windows

packageinspector.exe

PackageInspector allows creation of a catalog containing all executable files laid down by an installer · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • PACKAGEINSPECTOR.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\packageinspector.exe'
    - OriginalFileName: 'PACKAGEINSPECTOR.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
PACKAGEINSPECTOR.EXE1x6410.0.26100.3323Host scan✓ 1

InternalName: PackageInspector · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
87761316a305…10.0.26100.3323x64PACKAGEINSPECTOR.EXEHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.