Library / Windows

pathping.exe

TCP/IP PathPing Command · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 2

OriginalFilename

  • pathping.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\pathping.exe'
    - OriginalFileName: 'pathping.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
pathping.exe12x64, x8610.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 2

InternalName: pathping.exe · Product: Microsoft® Windows® Operating System

All 12 parsed builds · 28 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a140ff224af1…10.0.28000.1896x86pathping.exeWin11 26H1UnsignedWinbindex
0444c98f8ba5…10.0.28000.1896x64pathping.exeWin11 26H1Winbindex
cf755c161116…10.0.26100.8115x64pathping.exeWin11 24H2UnsignedHost scan, Winbindex✓
678a9f5494ac…10.0.26100.8115x86pathping.exeWin11 24H2UnsignedHost scan, Winbindex✓
e0adf9e5b96b…10.0.26100.5074x86pathping.exeWin11 24H2, Win11 25H2UnsignedWinbindex
5d3f6b3c7c33…10.0.26100.5074x64pathping.exeWin11 24H2, Win11 25H2UnsignedWinbindex
42765a6607f2…10.0.14393.0x86pathping.exeWin10 1607UnsignedWinbindex
3b2271e94d14…10.0.14393.0x64pathping.exeWin10 1607UnsignedWinbindex
b37b1da47ef6…10.0.10586.0x64pathping.exeWin10 1511UnsignedWinbindex
b2f55c0ba1d1…10.0.10586.0x86pathping.exeWin10 1511UnsignedWinbindex
a6fa32d23e5c…10.0.10240.16384x86pathping.exeWin10 1507UnsignedWinbindex
53d9e2f0c61f…10.0.10240.16384x64pathping.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.