Library / LOLBin

pcwrun.exe

Program Compatibility Troubleshooter Invoker · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 2

OriginalFilename

  • pcwrun.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\pcwrun.exe'
    - OriginalFileName: 'pcwrun.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
pcwrun.exe8x6410.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (10)Host scan, Winbindex✓ 1

InternalName: pcwrun.exe · Product: Microsoft® Windows® Operating System

All 8 parsed builds · 11 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
664cf59ab920…10.0.28000.1896x64pcwrun.exeWin11 26H1Winbindex
c505e8e9d5eb…10.0.26100.2161x64pcwrun.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
3de0d85f8170…10.0.17763.1x64pcwrun.exeWin10 1809UnsignedWinbindex
68bbe7b9f1c6…10.0.14393.0x64pcwrun.exeWin10 1607UnsignedWinbindex
eaaadd526a1e…10.0.10240.16384x64pcwrun.exeWin10 1507UnsignedWinbindex
cab37879a61e…10.0.19041.928x64pcwrun.exeWin10 2004, Win10 21H1Signed (Catalog file)Winbindex
cc079ab41ce6…10.0.16299.15x64pcwrun.exeWin10 1709UnsignedWinbindex
0dbbd7d4859b…10.0.10586.0x64pcwrun.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.