Library / LOLBin

pcwutl.dll

Program Compatibility Troubleshooter Helper · Microsoft Corporation

LOLBinWindowsParsedLOLBAS

OriginalFilename

  • pcwutl.dll

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\pcwutl.dll'
    - OriginalFileName: 'pcwutl.dll'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
pcwutl.dll13x6410.0.10240.16384 → 10.0.28000.3086Win10 1507 → Win11 26H1 (15)Winbindex

InternalName: pcwutl.dll · Product: Microsoft® Windows® Operating System

All 13 parsed builds · 5 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
fbbc685b3581…10.0.28000.3086x64pcwutl.dllWin11 26H1UnsignedWinbindex
609a6f364234…10.0.26100.9549x64pcwutl.dllWin11 24H2Winbindex
206a5c53ca99…10.0.14393.5291x64pcwutl.dllWin10 1607UnsignedWinbindex
e2f3a8679b5f…10.0.17763.1x64pcwutl.dllWin10 1809UnsignedWinbindex
cc90fb542b4d…10.0.10240.16384x64pcwutl.dllWin10 1507UnsignedWinbindex
f7b9b7b694b4…10.0.26100.5074x64pcwutl.dllWin11 24H2, Win11 25H2UnsignedWinbindex
26ed9adb6487…10.0.19041.2546x64pcwutl.dllWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
6dfbc59c5f26…10.0.19041.1266x64pcwutl.dllWin10 2004 … Win10 21H2 (3)Signed (Catalog file)Winbindex
94bf5ba8f533…10.0.22000.120x64pcwutl.dllWin11 21H2UnsignedWinbindex
5bbcba3493c1…10.0.18362.1832x64pcwutl.dllWin10 1909Winbindex
98fa9a34b804…10.0.19041.928x64pcwutl.dllWin10 2004, Win10 21H1Signed (Catalog file)Winbindex
de0923fcb4ef…10.0.16299.15x64pcwutl.dllWin10 1709UnsignedWinbindex
68eec847c88a…10.0.10586.0x64pcwutl.dllWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.