Library / Sysinternals

pendmoves.exe

Lists pending delayed movefile operations · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • pendmoves.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as pendmoves64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\pendmoves.exe'
    - OriginalFileName: 'pendmoves.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
pendmoves.exe1x861.3.0.0Sysinternals✓ 1

InternalName: PendMoves · Product: Sysinternals Pendmoves

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
e6fb98119483…1.3.0.0x86pendmoves.exeSysinternals PendmovesSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.