Library / Windows

pickerhost.exe

File Picker UI Host · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • PickerHost.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\pickerhost.exe'
    - OriginalFileName: 'PickerHost.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
PickerHost.exe2x64, x8610.0.26100.9549Host scan✓ 2

InternalName: PickerHost · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
52e6c93d41bc…10.0.26100.9549x64PickerHost.exeHost scan✓
02f3f7b3da23…10.0.26100.9549x86PickerHost.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.