Library / Sysinternals

pipelist.exe

Lists open named pipes · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • pipelist.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as pipelist64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\pipelist.exe'
    - OriginalFileName: 'pipelist.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
pipelist.exe1x861.3.0.0Sysinternals✓ 1

InternalName: PipeList · Product: Sysinternals PipeList

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
2e71a88fd832…1.3.0.0x86pipelist.exeSysinternals PipeListSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.