Library / LOLBin

pnputil.exe

Microsoft PnP Utility - Tool to add, delete, export, and enumerate driver packages. · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • pnputil.exe

Casing changed across builds

Gotchas

  • Casing differs across builds (PnPutil.exe, pnputil.exe). Case-sensitive comparisons (Elastic KQL on keyword fields, == in KQL/EQL) miss some builds.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\pnputil.exe'
    - OriginalFileName: 'pnputil.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
pnputil.exe5x6410.0.14393.2758 → 10.0.28000.3231Win10 1607 → Win11 26H1 (7)Host scan, Winbindex✓ 1
PnPutil.exe2x6410.0.10240.16384 → 10.0.10586.0Win10 1507 → Win10 1511 (2)Winbindex

InternalName: PnPutil.exe, pnputil.exe · Product: Microsoft® Windows® Operating System

All 7 parsed builds · 11 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
316fb5d3a0e7…10.0.28000.3231x64pnputil.exeWin11 26H1Winbindex
5c5783d49f8a…10.0.26100.9711x64pnputil.exeWin11 24H2UnsignedHost scan, Winbindex✓
d11ea7611a50…10.0.14393.2758x64pnputil.exeWin10 1607UnsignedWinbindex
4b443526b3c5…10.0.26100.6584x64pnputil.exeWin11 24H2, Win11 25H2UnsignedWinbindex
008e3ef11d66…10.0.19041.488x64pnputil.exeWin10 2004 … Win10 21H1 (3)Signed (Catalog file)Winbindex
29d15c46f164…10.0.10586.0x64PnPutil.exeWin10 1511UnsignedWinbindex
6fdbfb0d9b30…10.0.10240.16384x64PnPutil.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.