Library / Windows

poqexec.exe

Primitive Operations Queue Executor · Microsoft Corporation

WindowsParsed

OriginalFilename

  • poqexec.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\poqexec.exe'
    - OriginalFileName: 'poqexec.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
poqexec.exe2x64, x8610.0.26100.9703Host scan

InternalName: POQExec · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
b5076c36b979…10.0.26100.9703x64poqexec.exeHost scan
176304a5beed…10.0.26100.9703x86poqexec.exeHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.