Library / Windows

powershell.exe

Windows PowerShell · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 234

OriginalFilename

  • PowerShell.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\powershell.exe'
    - OriginalFileName: 'PowerShell.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
PowerShell.EXE14x64, x8610.0.10240.16384 → 10.0.28000.3086Win10 1507 → Win11 26H1 (11)Host scan, Winbindex✓ 2

InternalName: POWERSHELL · Product: Microsoft® Windows® Operating System

All 14 parsed builds · 18 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
83cb654d3fd2…10.0.28000.3086x64PowerShell.EXEWin11 26H1UnsignedWinbindex
0b3ac67c25f7…10.0.28000.3086x86PowerShell.EXEWin11 26H1UnsignedWinbindex
ad1be8f59817…10.0.26100.9549x86PowerShell.EXEWin11 24H2UnsignedHost scan, Winbindex✓
60c9b2984362…10.0.26100.9549x64PowerShell.EXEWin11 24H2UnsignedHost scan, Winbindex✓
ba4038fd20e4…10.0.14393.206x64PowerShell.EXEWin10 1607UnsignedWinbindex
813350226600…10.0.14393.206x86PowerShell.EXEWin10 1607UnsignedWinbindex
3bfedaaa40d9…10.0.26100.5074x86PowerShell.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
0ff6f2c94bc7…10.0.26100.5074x64PowerShell.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
9f914d42706f…10.0.19041.546x64PowerShell.EXEWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
73a3c4aef5de…10.0.19041.546x86PowerShell.EXEWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
bf6eccdaafaa…10.0.10586.0x86PowerShell.EXEWin10 1511UnsignedWinbindex
65554b6cabe2…10.0.10586.0x64PowerShell.EXEWin10 1511UnsignedWinbindex
c15644ddea9f…10.0.10240.16384x86PowerShell.EXEWin10 1507UnsignedWinbindex
8787d4b62488…10.0.10240.16384x64PowerShell.EXEWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.