Library / Windows

powershell_ise.exe

Windows PowerShell ISE · Microsoft Corporation

WindowsParsedSigma refs: 51

OriginalFilename

  • powershell_ise.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\powershell_ise.exe'
    - OriginalFileName: 'powershell_ise.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
powershell_ise.EXE14x64, x8610.0.10240.20793 → 10.0.26100.8875Win10 1507 → Win11 24H2 (7)Host scan, Winbindex

InternalName: POWERSHELL_ISE · Product: Microsoft® Windows® Operating System

All 14 parsed builds · 26 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d9fad49c293c…10.0.14393.4046x86powershell_ise.EXEWin10 1607UnsignedWinbindex
8cfac3f204df…10.0.14393.4046x64powershell_ise.EXEWin10 1607UnsignedWinbindex
47b09c724e70…10.0.10240.20793x86powershell_ise.EXEWin10 1507UnsignedWinbindex
0ce51ead5a83…10.0.10240.20793x64powershell_ise.EXEWin10 1507UnsignedWinbindex
a5b5a90b1d58…10.0.26100.1x64powershell_ise.EXEWin11 24H2UnsignedWinbindex
8351457dc487…10.0.26100.1x86powershell_ise.EXEWin11 24H2UnsignedWinbindex
a79e47618a8e…10.0.22621.1x86powershell_ise.EXEWin11 22H2, Win11 23H2Signed (Catalog file)Winbindex
19e8d60469bd…10.0.22621.1x64powershell_ise.EXEWin11 22H2, Win11 23H2Signed (Catalog file)Winbindex
ebe09fc291a3…10.0.10586.0x86powershell_ise.EXEWin10 1511UnsignedWinbindex
dbb2f0bcbeb9…10.0.10586.0x64powershell_ise.EXEWin10 1511UnsignedWinbindex
75242eb988ad…10.0.15063.0x86powershell_ise.EXEWin10 1703UnsignedWinbindex
6040b6479c86…10.0.15063.0x64powershell_ise.EXEWin10 1703UnsignedWinbindex
b4b1a489f51c…10.0.26100.8875x64powershell_ise.EXEHost scan
2698883aacaf…10.0.26100.8875x86powershell_ise.EXEHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.