Library / LOLBin

presentationhost.exe

Windows Presentation Foundation Host · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 2

OriginalFilename

  • PresentationHost.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\presentationhost.exe'
    - OriginalFileName: 'PresentationHost.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
PresentationHost.exe10x64, x8610.0.10240.17146 → 10.0.28000.1896Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 2

InternalName: PresentationHost.exe · Product: Microsoft® Windows® Operating System

All 10 parsed builds · 28 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
c09f0b93419f…10.0.28000.1896x64PresentationHost.exeWin11 26H1Winbindex
458239984cf8…10.0.28000.1896x86PresentationHost.exeWin11 26H1UnsignedWinbindex
a5538789d76f…10.0.26100.3624x86PresentationHost.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
0111d485351e…10.0.26100.3624x64PresentationHost.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
a571aa750b99…10.0.10240.17146x86PresentationHost.exeWin10 1507UnsignedWinbindex
259915b4bee6…10.0.10240.17146x64PresentationHost.exeWin10 1507UnsignedWinbindex
ef0751761e47…10.0.14393.0x86PresentationHost.exeWin10 1607UnsignedWinbindex
54be944eb17b…10.0.14393.0x64PresentationHost.exeWin10 1607UnsignedWinbindex
9e72305f7db3…10.0.10586.0x86PresentationHost.exeWin10 1511UnsignedWinbindex
344dc706ff0d…10.0.10586.0x64PresentationHost.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.