Library / Windows

prevhost.exe

Preview Handler Surrogate Host · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • PREVHOST.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\prevhost.exe'
    - OriginalFileName: 'PREVHOST.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
PREVHOST.EXE2x64, x8610.0.26100.8115Host scan✓ 2

InternalName: PREVHOST · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
faf57868029b…10.0.26100.8115x86PREVHOST.EXEHost scan✓
0402afd1e323…10.0.26100.8115x64PREVHOST.EXEHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.