Library / LOLBin

printbrm.exe

Print BRM command line tool · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • PrintBrm.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\printbrm.exe'
    - OriginalFileName: 'PrintBrm.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
PrintBrm.exe11x6410.0.10240.18608 → 10.0.28000.2804Win10 1507 → Win11 26H1 (14)Host scan, Winbindex✓ 1

InternalName: PrintBrm.exe · Product: Microsoft® Windows® Operating System

All 11 parsed builds · 6 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a0d2f0a376af…10.0.28000.2804x64PrintBrm.exeWin11 26H1Winbindex
6b84c5e63671…10.0.26100.9549x64PrintBrm.exeWin11 24H2UnsignedHost scan, Winbindex✓
71b5f4aa8d12…10.0.17763.1x64PrintBrm.exeWin10 1809UnsignedWinbindex
51cbee77a942…10.0.14393.4169x64PrintBrm.exeWin10 1607UnsignedWinbindex
74c61f2eb9a6…10.0.10240.18608x64PrintBrm.exeWin10 1507UnsignedWinbindex
275ab961e9c3…10.0.26100.5074x64PrintBrm.exeWin11 24H2, Win11 25H2UnsignedWinbindex
68dfb48a2a78…10.0.19041.450x64PrintBrm.exeWin10 2004 … Win10 21H2 (4)Signed (Catalog file)Winbindex
d2835b98e4f3…10.0.17134.1x64PrintBrm.exeWin10 1803UnsignedWinbindex
6307702ed58b…10.0.16299.15x64PrintBrm.exeWin10 1709UnsignedWinbindex
62763f069f8f…10.0.15063.0x64PrintBrm.exeWin10 1703UnsignedWinbindex
fca01b1ed397…10.0.10586.1106x64PrintBrm.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.