Library / Sysinternals

procdump64.exe

Sysinternals process dump utility · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 4

OriginalFilename

  • procdump

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: procdump64.exe never fires.
  • Same OriginalFilename as procdump.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\procdump64.exe'
    - OriginalFileName: 'procdump'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
procdump1x6412.2.0.0Sysinternals✓ 1

InternalName: ProcDump · Product: ProcDump

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
22c2a2b09ade…12.2.0.0x64procdumpProcDumpSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.