Library / Sysinternals

procmon.exe

Process Monitor · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 2

OriginalFilename

  • Process Monitor

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: procmon.exe never fires.
  • Same OriginalFilename as procmon64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\procmon.exe'
    - OriginalFileName: 'Process Monitor'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Process Monitor1x864.12.0.0Sysinternals✓ 1

InternalName: Process Monitor · Product: Sysinternals Procmon

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a7a2adcb8353…4.12.0.0x86Process MonitorSysinternals ProcmonSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.