Library / LOLBin

provlaunch.exe

Provisioning package runtime command launching tool · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 2

OriginalFilename

  • provlaunch

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: provlaunch.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\provlaunch.exe'
    - OriginalFileName: 'provlaunch'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
provlaunch10x64, x8610.0.10586.0 → 10.0.28000.1896Win10 1511 → Win11 26H1 (7)Host scan, Winbindex✓ 2

InternalName: provlaunch · Product: Microsoft® Windows® Operating System

All 10 parsed builds · 25 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d14e23770e45…10.0.28000.1896x86provlaunchWin11 26H1UnsignedWinbindex
ccf6eda3be36…10.0.28000.1896x64provlaunchWin11 26H1Winbindex
7c68a4e7473f…10.0.26100.8521x64provlaunchWin11 24H2UnsignedHost scan, Winbindex✓
0a5f73ef1680…10.0.26100.8521x86provlaunchWin11 24H2UnsignedHost scan, Winbindex✓
1336950ae552…10.0.14393.8146x64provlaunchWin10 1607UnsignedWinbindex
d411ceeb26a5…10.0.26100.3470x64provlaunchWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
99a922935a8a…10.0.26100.3470x86provlaunchWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
9f74b09f2d24…10.0.17763.1x64provlaunchWin10 1809UnsignedWinbindex
a61daf3657f2…10.0.17134.1x64provlaunchWin10 1803UnsignedWinbindex
e8883ac9a0ae…10.0.10586.0x64provlaunchWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.