Library / Windows

prproc.exe

PlayReady Process EXE · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • PlayReady Process EXE

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: prproc.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\prproc.exe'
    - OriginalFileName: 'PlayReady Process EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
PlayReady Process EXE1x6410.0.26100.1150Host scan✓ 1

InternalName: PlayReady Process EXE · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
20dedf92ede2…10.0.26100.1150x64PlayReady Process EXEHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.