Library / Sysinternals

psgetsid.exe

Translates SIDs to names and vice versa · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • PsGetSid.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as psgetsid64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\psgetsid.exe'
    - OriginalFileName: 'PsGetSid.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
PsGetSid.exe1x861.47.0.0Sysinternals✓ 1

InternalName: PsGetSid · Product: Sysinternals PsGetSid

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
8e642ed07ab7…1.47.0.0x86PsGetSid.exeSysinternals PsGetSidSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.