Library / Sysinternals

pskill.exe

Terminates processes on local or remote systems · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • pskill.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as pskill64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\pskill.exe'
    - OriginalFileName: 'pskill.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
pskill.exe1x861.18.0.0Sysinternals✓ 1

InternalName: PsKill · Product: Sysinternals PsKill

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
9048e3764c87…1.18.0.0x86pskill.exeSysinternals PsKillSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.