Library / Sysinternals

pslist64.exe

Process information lister · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • pslist.exe

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: pslist64.exe never fires.
  • Same OriginalFilename as pslist.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\pslist64.exe'
    - OriginalFileName: 'pslist.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
pslist.exe1x641.41.0.0Sysinternals✓ 1

InternalName: PsList · Product: Sysinternals PsList

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d3247f03dcd7…1.41.0.0x64pslist.exeSysinternals PsListSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.