Library / Sysinternals

pspasswd.exe

Local and remote password changer · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 2

OriginalFilename

  • pspasswd.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as pspasswd64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\pspasswd.exe'
    - OriginalFileName: 'pspasswd.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
pspasswd.exe1x861.25.0.0Sysinternals✓ 1

InternalName: PsPasswd · Product: Sysinternals PsPasswd

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
6ed5d50cf9d0…1.25.0.0x86pspasswd.exeSysinternals PsPasswdSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.