Library / Sysinternals

pspasswd64.exe

Local and remote password changer · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 2

OriginalFilename

  • pspasswd.exe

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: pspasswd64.exe never fires.
  • Same OriginalFilename as pspasswd.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\pspasswd64.exe'
    - OriginalFileName: 'pspasswd.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
pspasswd.exe1x641.25.0.0Sysinternals✓ 1

InternalName: PsPasswd · Product: Sysinternals PsPasswd

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
8d950068f46a…1.25.0.0x64pspasswd.exeSysinternals PsPasswdSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.