Library / Sysinternals

psping.exe

PsPing - ping, latency, bandwidth measurement utility · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • psping.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as psping64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\psping.exe'
    - OriginalFileName: 'psping.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
psping.exe1x862.13.0.0Sysinternals✓ 1

InternalName: PsPing · Product: Sysinternals PsPing

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
26249b06420a…2.13.0.0x86psping.exeSysinternals PsPingSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.