Library / Sysinternals

psping64.exe

PsPing - ping, latency, bandwidth measurement utility · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • psping.exe

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: psping64.exe never fires.
  • Same OriginalFilename as psping.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\psping64.exe'
    - OriginalFileName: 'psping.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
psping.exe1x642.13.0.0Sysinternals✓ 1

InternalName: PsPing · Product: Sysinternals PsPing

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
356448f935ba…2.13.0.0x64psping.exeSysinternals PsPingSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.