Library / Third-party

pwsh.dll

PowerShell 7 · Microsoft Corporation

Third-partyParsedSigma refs: 60

OriginalFilename

  • pwsh.dll

Shared with other binaries

Gotchas

  • Same OriginalFilename as pwsh.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\pwsh.dll'
    - OriginalFileName: 'pwsh.dll'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
pwsh.dll1x647.6.9.500Vendor

InternalName: pwsh.dll · Product: PowerShell

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
682c403fd13e…7.6.9.500x64pwsh.dllPowerShell 7Vendor

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.