Library / Windows

qappsrv.exe

Query Remote Desktop Session Host Server Utility · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • qappsrv.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\qappsrv.exe'
    - OriginalFileName: 'qappsrv.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
qappsrv.exe1x6410.0.26100.7623Host scan✓ 1

InternalName: qappsrv · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
5581617f747e…10.0.26100.7623x64qappsrv.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.