Library / LOLBin

query.exe

MultiUser Query Utility · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 7

OriginalFilename

  • query.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\query.exe'
    - OriginalFileName: 'query.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
query.exe6x64, x8610.0.10240.16384 → 10.0.26100.7623Win10 1507 → Win11 25H2 (5)Host scan, Winbindex✓ 1

InternalName: query · Product: Microsoft® Windows® Operating System

All 6 parsed builds · 17 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
93b86e70f5cf…10.0.26100.7623x86query.exeWin11 24H2UnsignedWinbindex
2824145efa3c…10.0.26100.7623x64query.exeWin11 24H2UnsignedHost scan, Winbindex✓
786f318fb104…10.0.26100.1x64query.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
0141b31c3583…10.0.14393.0x64query.exeWin10 1607UnsignedWinbindex
3ab2e760bc75…10.0.10586.0x64query.exeWin10 1511UnsignedWinbindex
b0486f51ad33…10.0.10240.16384x64query.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.