Library / Windows

rasdial.exe

Remote Access Command Line Dial UI · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • RASDIAL.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\rasdial.exe'
    - OriginalFileName: 'RASDIAL.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
RASDIAL.EXE12x64, x8610.0.10240.21161 → 10.0.28000.1Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 2

InternalName: RASDIAL.EXE · Product: Microsoft® Windows® Operating System

All 12 parsed builds · 28 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
f26f584ab6b3…10.0.28000.1x64RASDIAL.EXEWin11 26H1UnsignedWinbindex
4dfbf188fe8b…10.0.28000.1x86RASDIAL.EXEWin11 26H1UnsignedWinbindex
ca1d9bcbba17…10.0.26100.7705x86RASDIAL.EXEWin11 24H2UnsignedHost scan, Winbindex✓
be5c4522d41a…10.0.26100.7705x64RASDIAL.EXEWin11 24H2UnsignedHost scan, Winbindex✓
6014360a49f4…10.0.14393.8781x64RASDIAL.EXEWin10 1607UnsignedWinbindex
3303ec57afae…10.0.14393.8781x86RASDIAL.EXEWin10 1607UnsignedWinbindex
e59a1baf1919…10.0.26100.6584x86RASDIAL.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
b08791c7b805…10.0.26100.6584x64RASDIAL.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
f8053cd2ff50…10.0.10240.21161x64RASDIAL.EXEWin10 1507UnsignedWinbindex
1ca40b12b71a…10.0.10240.21161x86RASDIAL.EXEWin10 1507UnsignedWinbindex
d93d4403597a…10.0.10586.0x86RASDIAL.EXEWin10 1511UnsignedWinbindex
35ad0f9bf0fc…10.0.10586.0x64RASDIAL.EXEWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.