Library / Sysinternals

rdcman.exe

Remote Desktop Connection Manager · Microsoft

SysinternalsSysmon-confirmedSigma refs: 2

OriginalFilename

  • RDCMan.dll

Differs from file nameNames a DLL

Gotchas

  • OriginalFilename names a DLL (RDCMan.dll), not an executable. Rules expecting .exe values miss it.
  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: rdcman.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\rdcman.exe'
    - OriginalFileName: 'RDCMan.dll'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
RDCMan.dll1x643.22.0.0Sysinternals✓ 1

InternalName: RDCMan.dll · Product: Remote Desktop Connection Manager

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
fc4536b88b5b…3.22.0.0x64RDCMan.dllRemote Desktop Connection ManagerSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.