Library / Windows

rdpclip.exe

RDP Clipboard Monitor · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • rdpclip.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\rdpclip.exe'
    - OriginalFileName: 'rdpclip.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
rdpclip.exe16x6410.0.10240.20915 → 10.0.28000.3086Win10 1507 → Win11 26H1 (18)Host scan, Winbindex✓ 1

InternalName: rdpclip.exe · Product: Microsoft® Windows® Operating System

All 16 parsed builds · 2 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
8dd65549f22f…10.0.28000.3086x64rdpclip.exeWin11 26H1UnsignedWinbindex
0dbfa90e16fd…10.0.26100.9549x64rdpclip.exeWin11 24H2UnsignedHost scan, Winbindex✓
8fc237bc04e0…10.0.14393.9507x64rdpclip.exeWin10 1607UnsignedWinbindex
e03644d64e75…10.0.19041.7548x64rdpclip.exeWin10 21H2UnsignedWinbindex
8426cbf1e4ca…10.0.17763.8880x64rdpclip.exeWin10 1809UnsignedWinbindex
0ee67cf21b53…10.0.26100.4484x64rdpclip.exeWin11 24H2, Win11 25H2UnsignedWinbindex
13a916e4daf4…10.0.10240.20915x64rdpclip.exeWin10 1507UnsignedWinbindex
05781acada4b…10.0.19041.5794x64rdpclip.exeWin10 21H2, Win10 22H2UnsignedWinbindex
90f20999f933…10.0.22000.3260x64rdpclip.exeWin11 21H2UnsignedWinbindex
9d5be181d930…10.0.19041.746x64rdpclip.exeWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
255c19ac60a5…10.0.17134.1967x64rdpclip.exeWin10 1803UnsignedWinbindex
17fcbc9d1fc4…10.0.15063.2283x64rdpclip.exeWin10 1703UnsignedWinbindex
01dc9fd40e82…10.0.18362.836x64rdpclip.exeWin10 1903UnsignedWinbindex
936b3b37c343…10.0.16299.1715x64rdpclip.exeWin10 1709UnsignedWinbindex
0623210eaf00…10.0.18362.239x64rdpclip.exeWin10 1903, Win10 1909UnsignedWinbindex
63ed5b682b68…10.0.10586.839x64rdpclip.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.