Library / Windows

rdpsa.exe

RDP Session Agent · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • RdpSa.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\rdpsa.exe'
    - OriginalFileName: 'RdpSa.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
RdpSa.exe2x64, x8610.0.26100.9278Host scan✓ 2

InternalName: RdpSa.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
e02db0f2c64c…10.0.26100.9278x64RdpSa.exeHost scan✓
d9a196224e28…10.0.26100.9278x86RdpSa.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.