Library / Windows

rdpsaproxy.exe

RDP Session Agent Proxy · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • RdpSaProxy.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\rdpsaproxy.exe'
    - OriginalFileName: 'RdpSaProxy.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
RdpSaProxy.exe2x64, x8610.0.26100.9278Host scan✓ 2

InternalName: RdpSaProxy.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
b3409ad8fd48…10.0.26100.9278x64RdpSaProxy.exeHost scan✓
6bc6389d64d3…10.0.26100.9278x86RdpSaProxy.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.