Library / Windows

rdpsauachelper.exe

RDP Session Agent UAC Helper · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • RdpSaUacHelper.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\rdpsauachelper.exe'
    - OriginalFileName: 'RdpSaUacHelper.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
RdpSaUacHelper.exe2x64, x8610.0.26100.9444Host scan✓ 2

InternalName: RdpSaUacHelper.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
f2dede42c645…10.0.26100.9444x86RdpSaUacHelper.exeHost scan✓
a52415fe6638…10.0.26100.9444x64RdpSaUacHelper.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.