Library / Windows

rdpsign.exe

Remote Desktop Session Host Server Sign Tool · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • TSSignTool.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: rdpsign.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\rdpsign.exe'
    - OriginalFileName: 'TSSignTool.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
TSSignTool.exe1x6410.0.26100.9278Host scan✓ 1

InternalName: TSSignTool.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
7b322cfab0bc…10.0.26100.9278x64TSSignTool.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.