Library / LOLBin

reg.exe

Registry Console Tool · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 59

OriginalFilename

  • reg.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\reg.exe'
    - OriginalFileName: 'reg.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
reg.exe14x64, x8610.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (10)Host scan, Winbindex✓ 2

InternalName: reg.exe · Product: Microsoft® Windows® Operating System

All 14 parsed builds · 22 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
b905d255e891…10.0.28000.1896x64reg.exeWin11 26H1UnsignedWinbindex
4c91d5a369c3…10.0.28000.1896x86reg.exeWin11 26H1UnsignedWinbindex
ef37663b44ac…10.0.26100.5074x64reg.exeWin11 24H2, Win11 25H2UnsignedHost scan, Winbindex✓
91b607a875e9…10.0.26100.5074x86reg.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
fa035fe1340c…10.0.22000.653x86reg.exeWin11 21H2UnsignedWinbindex
4ed2a27860fa…10.0.18362.476x64reg.exeWin10 1903, Win10 1909UnsignedWinbindex
45eff48450c1…10.0.18362.476x86reg.exeWin10 1903, Win10 1909UnsignedWinbindex
e3046d83040d…10.0.17763.1x86reg.exeWin10 1809UnsignedWinbindex
cbb9f8d012cb…10.0.14393.0x86reg.exeWin10 1607UnsignedWinbindex
9e28034ce3ae…10.0.14393.0x64reg.exeWin10 1607UnsignedWinbindex
35c036facafb…10.0.10586.0x64reg.exeWin10 1511UnsignedWinbindex
34ab0dd6d065…10.0.10586.0x86reg.exeWin10 1511UnsignedWinbindex
e4721b35e0b2…10.0.10240.16384x64reg.exeWin10 1507UnsignedWinbindex
6b7560636f1b…10.0.10240.16384x86reg.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.