Library / Windows

regedt32.exe

Registry Editor Utility · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • regedt32.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\regedt32.exe'
    - OriginalFileName: 'regedt32.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
regedt32.exe2x64, x8610.0.26100.1882 → 10.0.26100.9278Host scan✓ 2

InternalName: regedt32.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
0e5a7d0434f4…10.0.26100.9278x64regedt32.exeHost scan✓
7738177a27de…10.0.26100.1882x86regedt32.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.