Library / LOLBin

regsvr32.exe

Microsoft(C) Register Server · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 67

OriginalFilename

  • REGSVR32.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\regsvr32.exe'
    - OriginalFileName: 'REGSVR32.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
REGSVR32.EXE13x64, x8610.0.10240.16384 → 10.0.28000.2804Win10 1507 → Win11 26H1 (7)Host scan, Winbindex✓ 2

InternalName: REGSVR32 · Product: Microsoft® Windows® Operating System

All 13 parsed builds · 27 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
bca87f2e8376…10.0.28000.2804x64REGSVR32.EXEWin11 26H1UnsignedWinbindex
aaf0e23e1dfd…10.0.28000.2804x86REGSVR32.EXEWin11 26H1UnsignedWinbindex
be1842d191dc…10.0.26100.9549x86REGSVR32.EXEWin11 24H2UnsignedHost scan, Winbindex✓
a207c231ed38…10.0.26100.9549x64REGSVR32.EXEWin11 24H2UnsignedHost scan, Winbindex✓
f72ed4d11c99…10.0.14393.1378x86REGSVR32.EXEWin10 1607UnsignedWinbindex
00a1cf85c6ab…10.0.14393.0x64REGSVR32.EXEWin10 1607UnsignedWinbindex
a47e25a9bdcf…10.0.26100.5074x64REGSVR32.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
40e7627f715b…10.0.26100.5074x86REGSVR32.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
8eb386c10e61…10.0.16299.248x64REGSVR32.EXEWin10 1709UnsignedWinbindex
a55a5e3c812c…10.0.10586.0x86REGSVR32.EXEWin10 1511UnsignedWinbindex
4a17f9c34c00…10.0.10586.0x64REGSVR32.EXEWin10 1511UnsignedWinbindex
bb1bb1e13b0b…10.0.10240.16384x86REGSVR32.EXEWin10 1507UnsignedWinbindex
8ccbd9d849fc…10.0.10240.16384x64REGSVR32.EXEWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.