Library / LOLBin

replace.exe

Replace File Utility · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • REPLACE.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\replace.exe'
    - OriginalFileName: 'REPLACE.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
REPLACE.EXE10x64, x8610.0.10240.16384 → 10.0.26100.1Win10 1507 → Win11 25H2 (7)Host scan, Winbindex✓ 2

InternalName: replace · Product: Microsoft® Windows® Operating System

All 10 parsed builds · 26 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
6686d1a489fb…10.0.26100.1x86REPLACE.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
0785c9b642c2…10.0.26100.1x64REPLACE.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
4bce5001002c…10.0.22000.653x86REPLACE.EXEWin11 21H2UnsignedWinbindex
883ac87a52b6…10.0.16299.15x64REPLACE.EXEWin10 1709UnsignedWinbindex
e6fc8fa07a57…10.0.14393.0x86REPLACE.EXEWin10 1607UnsignedWinbindex
ce49c1d7dc7c…10.0.14393.0x64REPLACE.EXEWin10 1607UnsignedWinbindex
8822af8ab175…10.0.10586.0x86REPLACE.EXEWin10 1511UnsignedWinbindex
0df1e70637ec…10.0.10586.0x64REPLACE.EXEWin10 1511UnsignedWinbindex
d087afae1405…10.0.10240.16384x86REPLACE.EXEWin10 1507UnsignedWinbindex
39c0cb8d34e1…10.0.10240.16384x64REPLACE.EXEWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.