Library / Windows

rmactivate.exe

Windows Rights Management Services Activation for Desktop Security Processor · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • rmactivate.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as rmactivate_isv.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\rmactivate.exe'
    - OriginalFileName: 'rmactivate.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
rmactivate.exe2x64, x8610.0.26100.4202Host scan✓ 2

InternalName: Windows Rights Management Services Activation for Desktop Security Processor · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
81b7205e9825…10.0.26100.4202x64rmactivate.exeHost scan✓
089509b99abf…10.0.26100.4202x86rmactivate.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.