Library / Windows

robocopy.exe

Microsoft Robocopy · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 8

OriginalFilename

  • robocopy.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\robocopy.exe'
    - OriginalFileName: 'robocopy.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
robocopy.exe20x64, x8610.0.10240.16384 → 10.0.28000.2804Win10 1507 → Win11 26H1 (13)Host scan, Winbindex✓ 2

InternalName: robocopy · Product: Microsoft® Windows® Operating System

All 20 parsed builds · 16 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
eece92dbbff5…10.0.28000.2804x86robocopy.exeWin11 26H1UnsignedWinbindex
bf99235e2abf…10.0.28000.2804x64robocopy.exeWin11 26H1UnsignedWinbindex
84abbd32d074…10.0.26100.9549x64robocopy.exeWin11 24H2UnsignedHost scan, Winbindex✓
3b25bd0d5c94…10.0.26100.9549x86robocopy.exeWin11 24H2UnsignedHost scan, Winbindex✓
02ff87dc35fb…10.0.17763.9376x64robocopy.exeWin10 1809UnsignedWinbindex
ef4885e50ecb…10.0.14393.5717x86robocopy.exeWin10 1607UnsignedWinbindex
676263620ca8…10.0.14393.5717x64robocopy.exeWin10 1607UnsignedWinbindex
ea6da9c1a1b6…10.0.26100.5074x64robocopy.exeWin11 24H2, Win11 25H2UnsignedWinbindex
5670c9b8c7d2…10.0.26100.5074x86robocopy.exeWin11 24H2, Win11 25H2UnsignedWinbindex
4659277dfec2…10.0.19041.2546x64robocopy.exeWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
09ae80f118b7…10.0.19041.2546x86robocopy.exeWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
e6b8f3d26fe3…10.0.18362.1832x64robocopy.exeWin10 1909UnsignedWinbindex
172a501d056b…10.0.18362.1832x86robocopy.exeWin10 1909UnsignedWinbindex
7ae822b1f50e…10.0.15063.674x64robocopy.exeWin10 1703UnsignedWinbindex
01b185ecff68…10.0.15063.674x86robocopy.exeWin10 1703UnsignedWinbindex
83428f8fd1cf…10.0.17134.1x86robocopy.exeWin10 1803UnsignedWinbindex
dd7afc40ca4f…10.0.10586.0x64robocopy.exeWin10 1511UnsignedWinbindex
d5c904c1a365…10.0.10586.0x86robocopy.exeWin10 1511UnsignedWinbindex
c9fbadf1ddec…10.0.10240.16384x64robocopy.exeWin10 1507UnsignedWinbindex
444dd1b9bcdf…10.0.10240.16384x86robocopy.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.