Library / Windows

route.exe

TCP/IP Route Command · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 3

OriginalFilename

  • route.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\route.exe'
    - OriginalFileName: 'route.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
route.exe11x64, x8610.0.10240.16384 → 10.0.28000.2804Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 2

InternalName: route.exe · Product: Microsoft® Windows® Operating System

All 11 parsed builds · 28 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
0b5a1019f8f4…10.0.28000.2804x64route.exeWin11 26H1UnsignedWinbindex
b65731d415a2…10.0.28000.1x86route.exeWin11 26H1UnsignedWinbindex
ac348f503a75…10.0.26100.9549x64route.exeWin11 24H2UnsignedHost scan, Winbindex✓
a460078cc5e9…10.0.26100.2161x86route.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
bfe7a626bf3b…10.0.14393.0x64route.exeWin10 1607UnsignedWinbindex
3bc0a2c1f62b…10.0.14393.0x86route.exeWin10 1607UnsignedWinbindex
2987a6ae73db…10.0.26100.2161x64route.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
d67ba8918ed8…10.0.10586.0x86route.exeWin10 1511UnsignedWinbindex
95ba19dee2ac…10.0.10586.0x64route.exeWin10 1511UnsignedWinbindex
b621b9b8215a…10.0.10240.16384x64route.exeWin10 1507UnsignedWinbindex
5f7b588e734d…10.0.10240.16384x86route.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.