Library / LOLBin

rpcping.exe

RPC Ping Utility · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • RpcPing.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\rpcping.exe'
    - OriginalFileName: 'RpcPing.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
RpcPing.exe16x64, x8610.0.10240.18158 → 10.0.26100.1882Win10 1507 → Win11 25H2 (9)Host scan, Winbindex✓ 2

InternalName: RpcPing.exe · Product: Microsoft® Windows® Operating System

All 16 parsed builds · 20 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
53d329298562…10.0.26100.1882x86RpcPing.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
0244aa8269c3…10.0.26100.1882x64RpcPing.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
5075148b8c0c…10.0.17763.1911x86RpcPing.exeWin10 1809UnsignedWinbindex
4dfa8a45c603…10.0.17763.1911x64RpcPing.exeWin10 1809UnsignedWinbindex
da02a31325f1…10.0.14393.2879x64RpcPing.exeWin10 1607UnsignedWinbindex
1be248078120…10.0.14393.2879x86RpcPing.exeWin10 1607UnsignedWinbindex
f1b59c0a30b1…10.0.10240.18158x86RpcPing.exeWin10 1507UnsignedWinbindex
d4f9b96f8d29…10.0.10240.18158x64RpcPing.exeWin10 1507UnsignedWinbindex
9e3d8ee08a87…10.0.17134.677x86RpcPing.exeWin10 1803UnsignedWinbindex
8d293b415249…10.0.17134.677x64RpcPing.exeWin10 1803UnsignedWinbindex
9ecb20b9edff…10.0.15063.1716x64RpcPing.exeWin10 1703UnsignedWinbindex
7316e4edbc40…10.0.15063.1716x86RpcPing.exeWin10 1703UnsignedWinbindex
f6d2dfa110bc…10.0.16299.1059x64RpcPing.exeWin10 1709UnsignedWinbindex
13c4e634286f…10.0.16299.1059x86RpcPing.exeWin10 1709UnsignedWinbindex
9888fee48cee…10.0.10586.0x86RpcPing.exeWin10 1511UnsignedWinbindex
831ed7b30efc…10.0.10586.0x64RpcPing.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.