Library / Sysinternals

ru64.exe

Registry size usage reporter · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • Regsize1

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: ru64.exe never fires.
  • Same OriginalFilename as ru.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\ru64.exe'
    - OriginalFileName: 'Regsize1'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Regsize11x641.20.0.0Sysinternals✓ 1

InternalName: Ru · Product: Sysinternals Ru

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
c48a4859ac61…1.20.0.0x64Regsize1Sysinternals RuSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.