Library / LOLBin

rundll32.exe

Windows host process (Rundll32) · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 108

OriginalFilename

  • RUNDLL32.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\rundll32.exe'
    - OriginalFileName: 'RUNDLL32.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
RUNDLL32.EXE21x64, x8610.0.10240.20822 → 10.0.28000.2804Win10 1507 → Win11 26H1 (15)Host scan, Winbindex✓ 2

InternalName: rundll · Product: Microsoft® Windows® Operating System

All 21 parsed builds · 11 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
b86b06438f8f…10.0.28000.2804x86RUNDLL32.EXEWin11 26H1UnsignedWinbindex
24aaef695d7b…10.0.28000.2804x64RUNDLL32.EXEWin11 26H1UnsignedWinbindex
dc41380d0c96…10.0.26100.9549x64RUNDLL32.EXEWin11 24H2UnsignedHost scan, Winbindex✓
ca3176c675bc…10.0.26100.9549x86RUNDLL32.EXEWin11 24H2UnsignedHost scan, Winbindex✓
9f1e56a3bf29…10.0.17763.1697x64RUNDLL32.EXEWin10 1809UnsignedWinbindex
9980cc59993d…10.0.14393.4169x86RUNDLL32.EXEWin10 1607UnsignedWinbindex
28de7d3e8bf4…10.0.14393.4169x64RUNDLL32.EXEWin10 1607UnsignedWinbindex
238eb6d00c29…10.0.26100.5074x86RUNDLL32.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
2370d904f3c1…10.0.26100.5074x64RUNDLL32.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
a89e46dfa01f…10.0.10240.20822x86RUNDLL32.EXEWin10 1507UnsignedWinbindex
45fffd7e2f11…10.0.10240.20822x64RUNDLL32.EXEWin10 1507UnsignedWinbindex
c28108f9dd1b…10.0.22621.4746x86RUNDLL32.EXEWin11 22H2UnsignedWinbindex
344fe666b811…10.0.22621.4746x64RUNDLL32.EXEWin11 22H2UnsignedWinbindex
b53f3c0cd32d…10.0.19041.746x64RUNDLL32.EXEWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
6cbe0e1f046b…10.0.19041.746x86RUNDLL32.EXEWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
c6ca51e46aa9…10.0.17134.1967x64RUNDLL32.EXEWin10 1803UnsignedWinbindex
50e7c39ddb4f…10.0.17134.1967x86RUNDLL32.EXEWin10 1803UnsignedWinbindex
ee199958132f…10.0.15063.2614x64RUNDLL32.EXEWin10 1703UnsignedWinbindex
4d3fad632631…10.0.15063.2614x86RUNDLL32.EXEWin10 1703UnsignedWinbindex
d884b06dbb81…10.0.10586.0x86RUNDLL32.EXEWin10 1511UnsignedWinbindex
594e6e07bc6b…10.0.10586.0x64RUNDLL32.EXEWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.