Library / LOLBin

runexehelper.exe

Microsoft (R) Run Exe Helper · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • RunExeHelper.exe

Some builds lack OriginalFilename

Gotchas

  • 10 observed builds carry no OriginalFilename at all.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\runexehelper.exe'
    - OriginalFileName: 'RunExeHelper.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
none10x64Win10 1709 → Win11 21H2 (11)Winbindex
RunExeHelper.exe3x6410.0.26100.5074 → 10.0.28000.3231Win11 24H2 → Win11 26H1 (3)Host scan, Winbindex✓ 1

InternalName: RunExeHelper · Product: Microsoft® Windows® Operating System

All 13 parsed builds · 2 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
f755d993d1e9…10.0.28000.3231x64RunExeHelper.exeWin11 26H1Winbindex
3ab33284afb9…10.0.26100.9711x64RunExeHelper.exeWin11 24H2UnsignedHost scan, Winbindex✓
e03700015dcc…x64noneWin10 21H2, Win10 22H2UnsignedWinbindex
9d461ceaf186…x64noneWin10 1809UnsignedWinbindex
87fc66b4749e…10.0.26100.5074x64RunExeHelper.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
421b05232d8e…x64noneWin11 21H2UnsignedWinbindex
f6a6168bccb7…x64noneWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
2a3dc3ee6541…x64noneWin10 2004 … Win10 22H2 (3)UnsignedWinbindex
18aac41761e2…x64noneWin10 1909UnsignedWinbindex
fc3ddd32d1c8…x64noneWin10 1903, Win10 1909UnsignedWinbindex
d0426ae4bdf1…x64noneWin10 2004, Win10 21H1Signed (Catalog file)Winbindex
41bdf4d68ec3…x64noneWin10 1803UnsignedWinbindex
1bf69e28a2d2…x64noneWin10 1709UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.