Library / LOLBin

runonce.exe

Run Once Wrapper · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 3

OriginalFilename

  • RUNONCE.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\runonce.exe'
    - OriginalFileName: 'RUNONCE.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
RUNONCE.EXE23x64, x8610.0.10240.16384 → 10.0.28000.2804Win10 1507 → Win11 26H1 (15)Host scan, Winbindex✓ 2

InternalName: RunOnce · Product: Microsoft® Windows® Operating System

All 23 parsed builds · 11 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
9a08e7a6cb42…10.0.28000.2804x86RUNONCE.EXEWin11 26H1UnsignedWinbindex
534cdec68d09…10.0.28000.2804x64RUNONCE.EXEWin11 26H1UnsignedWinbindex
3c1f7d2e0767…10.0.26100.9549x86RUNONCE.EXEWin11 24H2UnsignedHost scan, Winbindex✓
1de8d7cca99c…10.0.26100.9549x64RUNONCE.EXEWin11 24H2UnsignedHost scan, Winbindex✓
b47558166bfe…10.0.17763.1697x64RUNONCE.EXEWin10 1809Signed (Catalog file)Winbindex
e7df229c54ab…10.0.14393.4169x86RUNONCE.EXEWin10 1607UnsignedWinbindex
d8c445d9ce36…10.0.14393.4169x64RUNONCE.EXEWin10 1607UnsignedWinbindex
73a45d49a0a7…10.0.26100.5074x86RUNONCE.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
0291486041a5…10.0.26100.5074x64RUNONCE.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
5c964054e23a…10.0.22000.653x64RUNONCE.EXEWin11 21H2UnsignedWinbindex
4dfe3a43c478…10.0.22000.653x86RUNONCE.EXEWin11 21H2UnsignedWinbindex
4dbc301ea051…10.0.19041.1202x86RUNONCE.EXEWin10 2004 … Win10 22H2 (4)UnsignedWinbindex
25ea6b86f6e6…10.0.19041.1202x64RUNONCE.EXEWin10 2004 … Win10 22H2 (4)UnsignedWinbindex
0babaeacf9d0…10.0.19041.746x86RUNONCE.EXEWin10 2004, Win10 21H1Signed (Catalog file)Winbindex
0779370f528f…10.0.19041.746x64RUNONCE.EXEWin10 2004, Win10 21H1Signed (Catalog file)Winbindex
d85207820823…10.0.17134.1967x64RUNONCE.EXEWin10 1803UnsignedWinbindex
cb2a355aaf05…10.0.17134.1967x86RUNONCE.EXEWin10 1803UnsignedWinbindex
32c9171f3a77…10.0.15063.2614x86RUNONCE.EXEWin10 1703UnsignedWinbindex
2bc3682b7e48…10.0.15063.2614x64RUNONCE.EXEWin10 1703UnsignedWinbindex
c1349f75f6c3…10.0.10586.0x86RUNONCE.EXEWin10 1511UnsignedWinbindex
b06b657a8273…10.0.10586.0x64RUNONCE.EXEWin10 1511UnsignedWinbindex
bb684175b4a0…10.0.10240.16384x64RUNONCE.EXEWin10 1507UnsignedWinbindex
3a001b8c4d0e…10.0.10240.16384x86RUNONCE.EXEWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.