Library / LOLBin

scp.exe

LOLBinWindowsParsedLOLBAS

OriginalFilename

None. No observed build carries an OriginalFilename, so sensors log -.

No OriginalFilename

Gotchas

  • No OriginalFilename in any observed build, so Sysmon logs - and OriginalFileName rules can't match it. Anchor on the image path, hash or signer instead.

Query snippets

# No OriginalFilename in any observed build: match on the image instead
logsource:
  category: process_creation
  product: windows
detection:
  selection:
    Image|endswith: '\scp.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
none8x647.6.0.0 → 9.5.6.4Win10 1803 → Win11 26H1 (15)Host scan, Winbindex
All 8 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
b9cc1ae5fdba…9.5.6.4x64noneWin11 24H2, Win11 26H1UnsignedHost scan, Winbindex
c095c4ee6805…9.5.5.3x64noneWin10 1809 … Win11 23H2 (3)UnsignedWinbindex
26a44135c23d…9.5.5.1x64noneWin10 1809 … Win11 25H2 (4)Signed (Catalog file)Winbindex
29328a55ab58…9.5.4.1x64noneWin10 1809 … Win11 24H2 (6)UnsignedWinbindex
a91517a804fc…9.5.2.1x64noneWin10 1809 … Win11 24H2 (6)UnsignedWinbindex
9f109ced3d57…8.1.0.1x64noneWin10 2004 … Win10 22H2 (4)UnsignedWinbindex
8860e4273f59…7.7.2.1x64noneWin10 1809 … Win10 21H1 (6)Signed (Catalog file)Winbindex
fe116afc3d32…7.6.0.0x64noneWin10 1803UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.