Library / Windows

scrcons.exe

WMI Standard Event Consumer - scripting · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 7

OriginalFilename

  • ScrCons

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: scrcons.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\scrcons.exe'
    - OriginalFileName: 'ScrCons'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
ScrCons6x6410.0.10240.17797 → 10.0.28000.1896Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 1

InternalName: ScrCons · Product: Microsoft® Windows® Operating System

All 6 parsed builds · 14 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
877426e95dbe…10.0.28000.1896x64ScrConsWin11 26H1Winbindex
e99cba8b5ede…10.0.26100.7019x64ScrConsWin11 24H2UnsignedHost scan, Winbindex✓
87d8af6c1c73…10.0.26100.1882x64ScrConsWin11 24H2, Win11 25H2UnsignedWinbindex
e4aa4dbff38e…10.0.10240.17797x64ScrConsWin10 1507UnsignedWinbindex
7154b0624717…10.0.14393.0x64ScrConsWin10 1607UnsignedWinbindex
cd9cab47d032…10.0.10586.0x64ScrConsWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.